Assistance E-connecteur

Erreur 1002-2, le webservice n'est pas opérationnel

Symptômes :

  • Prestashop 1.6
  • Message dans les journaux E-connecteur : "Erreur 1002-2 (http 500) :"
  • Message dans E-connecteur Report Online et les journaux "Erreur, le webservice n'est pas opérationnel. Si le problème persiste, contactez votre agence web." et bien sûr cela persiste


Contrôle supplémentaire à faire : Ouvrir le webservice de Prestashop avec le navigateur. Il affiche un message d'erreur du type :

[PHP Warning #2] count(): Parameter must be an array or an object that implements Countable (web/classes/webservice/WebserviceRequest.php, line 794)


Cela vient du fait que l'hébergeur a mis à jour la version de php, vers la version 7.2 ou supérieure et que la version de Prestashop 1.6 utilisée n'est pas compatible.

Il est nécessaire que l'agence web du client s'assure de la compatibilité entre Prestashop et php. La société Prestashop ne supporte plus la version 1.6, aussi nous recommandons de passer à Prestashop 1.7.

Il existe cependant une version communautaire pouvant aider au support de php 7.2. Elle est disponible ici : https://github.com/PrestaShop/PrestaShop-1.6

Cette réponse a-t-elle été utile ? Oui Non

Envoyer vos commentaires
Nous sommes désolés de ne pas avoir pu répondre à votre question. Aidez-nous à améliorer cet article grâce à vos commentaires.