Prérequis matériels et logiciels pour E-connecteur

Maxime

Modifié le : Lun, 24 Juin, 2024 à 4:30 H

Prérequis CMS E-Commerce


PrestaShop :


  • Versions 1.4  à 1.7, avec webservice actif et fonctionnel
  • Versions 8.0.0 à 8.0.3 sous réserve d'application de ce patch Prestashop, et avec avec webservice actif et fonctionnel
  • Version 8.0.4 et supérieure (8.0.x), avec webservice actif et fonctionnel
  • Version 8.1.x et supérieure (8.1.x), sous réserve d'application de ce patch Prestashop, ainsi que celui-ci (si vous souhaitez piloter les images) et avec avec webservice actif et fonctionnel. Ces patchs sont appliqués à partir de la version 8.1.2.


Notez que dans certains contextes d'utilisation, vous pourriez avoir besoin d'appliquer certains patchs sur Prestashop pour en corriger des anomalies. Par exemple, si vous utilisez des grilles de prix par client, vous auriez ce patch à faire.



WooCommerce :


  • Version 2.2 et supérieure, avec webservice actif et fonctionnel 


Shopify : 


  • Avoir accès à la création d'application pour pouvoir créer une application privée.


Magento : 


  • Pour Magento, version 1.6 à 2.4.6, avec webservice SOAP actif  et fonctionnel



Autre CMS :

 



En Complément :


Vous ne devez pas avoir d'outils bloquant le nombre d'appels http sur le serveur. Pour cela, un serveur dédié avec un infogérant pouvant adapter la configuration du serveur selon vos besoins est fortement recommandé.

Au-delà de 5 000 grilles de prix à envoyer par jour, nous recommandons un accès distant à MySQL pour une mise à jour plus rapide. 



Prérequis Gestion commerciale 



EBP Gestion Commerciale Openline en mode desktop : 


  • Éditions : Activ, PRO, Elit, toute version (y compris Point de Vente Openline)
  • Module SDK (à demander à votre revendeur EBP)
  • Accès SQL Server avec utilisateur SQL (c'est le standard EBP)
  • Imports paramétrables des tiers clients et des pièces de vente.


EBP Saas :


  • Accès API ouvert (disponible sur les contrats Premium et Silver).


À noter : Les accès aux logiciels EBP SaaS sont des accès via une API fournie par EBP, qui peut avoir des limitations techniques en termes de volumétrie, de fréquence de mise à jour ou de rapidité supérieures aux capacités du logiciel E-connecteur. Nous recommandons une étude technique de faisabilité au-delà de 10 000 opérations d'écritures par jour. Vous disposez d'un paramétrage E-connecteur pouvant être lancé au maximum toutes les heures. Si vous souhaitez plusieurs paramétrages différents ou une fréquence particulière, cela est disponible sur devis.



Sage Ligne 100 Gestion Commerciale :


  • Version :  i7.50 et supérieure avec une licence utilisateur "Extension Objet"
  • Accès SQL Server en lecture obligatoire


Conformément aux dispositions prises par l'éditeur Sage le 27/01/20, l'assistance et la maintenance de la gamme Sage 100 étant arrêté à compter du 30/06/21, Vaisonet n'assurera plus également l'assistance et la maintenance du logiciel E-connecteur pour Sage 100. La mise à jour vers 100c est recommandée.



Sage Ligne 100c Gestion Commerciale : 


  • Versions : Toutes (y compris SPC)
  • Accès SQL Server ou Azure SQL (en lecture seule)
  • Une version 3.0 ou supérieure est nécessaire si vous souhaitez activer l'envoi des factures validées Sage en PDF sur le site.



Ciel Gestion Commerciale : 


  • Versions : 12 à 23 incluses.



Sage 50c Ciel Gestion Commerciale : 


  • Versions : Toutes



Wavesoft Gestion Commerciale : 


  • Version : 16 et supérieure
  • Module automate de transfert
  • Accès SQL Server avec utilisateur SQL (c'est le standard Wavesoft).




Concernant l'écriture en gestion commerciale, il est possible de traiter plusieurs centaines de commandes par jour, au-delà, consultez nous pour une étude.


Prérequis hébergement web


Certains hébergements limitent le nombre de requêtes HTTP maximal. Ce nombre doit être adapté à votre volumétrie de données afin de permettre l'envoi total des données. Les protocoles SSLv2, SSLv3, TLS v1.0, TLS v1.1, TLS v1.2 sont supportés.



Limites de traitement


La volumétrie des données envoyées sur un site e-commerce et pouvant être traitée par E-connecteur dépends des performances du site internet lui-même. C'est le goulot d'étranglement (notez qu'E-connecteur utilise un système de cache différentiel pour limiter et optimiser les appels aux webservices).


    

Il n'y a pas de limite théorique atteignable, mais il y a une durée de mise à jour tellement longue qu'elle ne sera pas compatible avec votre activité. Nos clients peuvent traiter 10 à 15 000 produits sans contrainte particulière, au-delà, consultez nous pour une étude.



Prérequis système d'exploitation

Toute version de Windows supportée par Microsoft : Windows 10, 11, Server 2016, Server 2019, Server avec une session administrateur.



Prérequis téléintervention


En cas d'installation par Vaisonet, ou de demande de téléintervention, vous devez utiliser l'application Splashtop SOS, fournie par Vaisonet. Aucune autre modalité de connexion (VPN, Teamviewer, Anydesk, etc.) ne pourra être utilisée.



Prérequis matériel


Spécification

E-connecteur

Minimum

Recommandé

CPU

Intel Pentium G5400T (3,1 GHz)

i3-6100T (3,2 GHz)/ Ryzen 3 1200 (3,1GHz)

Mémoire RAM

3 Go

4 Go

Stockage disponible

3 Go

10 Go (SSD)

Notes

- Connexion internet stable et permanente

- Une interface graphique est nécessaire

- L'utilisateur au quotidien du logiciel E-connecteur doit avoir accès à la session utilisée pour l'installation.


- Les marques, matériels et logiciels cités sont à acquérir indépendamment des logiciels Vaisonet. 

- Tous les logiciels, système d'exploitation et pilotes matériels notamment doivent être à jour. 

- Les ports TCP / UDP 53 (sur l'IP 8.8.8.8), 80, 123, 443 doivent être autorisés en sortie sur le poste possédant E-Connecteur

- Les connexions entrantes sur le site web sur son webservice ne doivent pas être limitées.





Cet article a-t-il été utile ?

C'est super !

Merci pour votre commentaire

Désolé ! Nous n'avons pas pu vous être utile

Merci pour votre commentaire

Dites-nous comment nous pouvons améliorer cet article !

Sélectionner au moins l'une des raisons
La vérification CAPTCHA est requise.

Commentaires envoyés

Nous apprécions vos efforts et nous allons corriger l'article