Que faire avec le message "Votre agence web doit corriger les erreurs PHP suivantes" ?

Maxime

Modifié le : Jeu, 4 Août, 2022 at 6:29 H

Votre rapport E-connecteur Report Online mentionne le message "Votre agence web doit corriger les erreurs PHP suivantes" suivi d'un message d'erreur technique.


Il s'agit là d'une anomalie de fonctionnement du webservice de Prestashop.


Le message d'erreur technique est l'anomalie rencontrée par Prestashop, qu'un développeur PHP expérimenté sera à même d'analyser et de vous proposer une solution pour faire fonctionner correctement Prestashop et par là même, E-connecteur.


D'expérience, avant toute chose, nous invitons nos clients à vérifier que l'hébergement web utilise bien une version de php supportée par Prestashop (https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/). 

C'est une erreur fréquente que l'on rencontre. 

Notez que si vous utilisez Prestashop 1.7.8 et PHP 7.4, plusieurs de nos clients ont constaté des soucis que le passage à PHP 7.3 a résolu (quand bien même 7.4 est la version recommandée par Prestashop).


Votre agence aura besoin d'élément pour corriger. Elle ne pourra pas corriger un dysfonctionnement qu'elle ne voit pas. Le message d'erreur technique affiché dans le rapport E-connecteur Report Online suffit très généralement. 

Parfois, elle peut avoir besoin de reproduire le dysfonctionnement, c'est-à-dire refaire elle-même, indépendamment d'E-connecteur, l'appel au webservice.

Cela est possible, à partir de la version 6.4.203 du logiciel E-connecteur (sauf pour EBP SaaS), en fournissant à votre agence web le fichier C:\ProgramData\Vaisonet\Connecteur\trace.php.

Cet article a-t-il été utile ?

C'est super !

Merci pour votre commentaire

Désolé ! Nous n'avons pas pu vous être utile

Merci pour votre commentaire

Dites-nous comment nous pouvons améliorer cet article !

Sélectionner au moins l'une des raisons

Commentaires envoyés

Nous apprécions vos efforts et nous allons corriger l'article